'Checksum failed' Error when Transferring Data to Windows XP

The information provided is for help with Commtest Instruments products:

  • MAS software, Profiler instrument



PROBLEM

When downloading data from the instrument this error message appears:

'Checksum failed. There appears to be a communications problem.'

CAUSE

We have experienced some instances where brand new computers, often with fast processors, do have some communications difficulties. There is a known issue in Windows XP systems that causes duplication of received data packets. This in turn causes the failure of the serial communication data transfer checksum.

SOLUTION

  1. Download and install the latest MAS software from the Commtest website. Use the menu bar links to locate the software under Products>Profiler>Instrument. This is a free upgrade designed to fix the checksum error. If this does not resolve the problem proceed with solution 2 below.
  2. If your MAS software fails with Windows XP but worked well under a previous version of Windows, try using Windows Compatiblity Mode. Compatibility mode emulates previous versions of Windows such as Windows 95, 98, Me, 2000 or NT 4.0. When Windows XP is run in compatibility mode it will 'pretend' to be a different operating system so that older software will continue to run on it.

To try and fix the problem follow the steps below.

  • On the Windows Start menu navigate to the submenu containing the MAS icon. Right-click this and select 'Properties'.

MAS_Properties_Window

  • Click the 'Compatibility' tab to see the available options.

MAS_Compatiblity_Mode

  • Click 'Run this program in compatibility mode for:' and select an operating system from the drop-down list that you have previously used to run MAS successfully.
  • Click OK to apply the settings and close the window.
  • We recommend that you also modify your MAS desktop shortcut to prevent anyone accidentally running the program in the incorrect mode. Right-click the desktop shortcut, select 'Properties' and carry out the same steps as previously.
  • Start the Ascent program to test if it works okay and if necessary change your selection to a different operating system until you find the compatibility mode which offers the greatest stability.

If you have any questions or require assistance please contact the Commtest support team.

FAQ ID: 13778 Last Reviewed: 2 February 2007